Проникающая гидроизоляция бетона
| Правила | Регистрация | Пользователи | Поиск | Сообщения за день | Все разделы прочитаны |  Справка по форуму | Файлообменник |

Вернуться   Форум DWG.RU > Программное обеспечение > Программирование > LISP > Проблема с присвоением значения (Lisp)

Проблема с присвоением значения (Lisp)

Ответ
Поиск в этой теме
Непрочитано 09.05.2006, 13:48 #1
Проблема с присвоением значения (Lisp)
DEM
 
YngIngKllr
 
СПб
Регистрация: 29.03.2005
Сообщений: 12,783

Прблема с присвоением значения
вот кусок проблемного кода
Код:
[Выделить все]
 (command "_.text" pt2 2.5 0 P)
  (setg L (strlen P))
  (setq pt3 (list (+ (nth 0 pt1) L) (nth 1 pt1) (nth 2 pt1)))
  (command "_.pline" pt2 pt3 "")
atoi и atof результата на дают
__________________
Шаг 12й......
Мои публикации
Просмотров: 1205
 
Непрочитано 09.05.2006, 14:16
#2
Profan


 
Регистрация: 25.12.2005
Москва
Сообщений: 13,663


Прежде всего, надо исправить setg на setq.
Я составил такую программку:
Код:
[Выделить все]
(apply '(lambda ()
(setq pt1 (getpoint "\n Укажите 1 точку: "))
(setq pt2 (getpoint "\n Укажите 2 точку: "))
(setq p "Проверка")
(command "_.text" pt2 2.5 0 P) 
(setq L (strlen P)) 
(setq pt3 (list (+ (nth 0 pt1) L) (nth 1 pt1) (nth 2 pt1))) 
(command "_.pline" pt2 pt3 "")
(princ)
)
'()
)
Все работает.
Не знаю, правда, что у вас скрывается в переменной P. Может быть, текст без кавычек?
Profan вне форума  
 
Автор темы   Непрочитано 09.05.2006, 17:39 Привет
#3
DEM

YngIngKllr
 
Регистрация: 29.03.2005
СПб
Сообщений: 12,783


Спасибо :%))))))
А то сижу разбираюсь (туплю)
__________________
Шаг 12й......
Мои публикации
DEM вне форума  
Ответ
Вернуться   Форум DWG.RU > Программное обеспечение > Программирование > LISP > Проблема с присвоением значения (Lisp)

Размещение рекламы
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск