Архитекторам и проектировщикам
| Правила | Регистрация | Пользователи | Поиск | Сообщения за день | Все разделы прочитаны |  Справка по форуму | Файлообменник |

Вернуться   Форум DWG.RU > Программное обеспечение > Программирование > Какой лучше .NET Framework при разработке ?

Какой лучше .NET Framework при разработке ?

Ответ
Поиск в этой теме
Непрочитано 26.10.2020, 10:21 #1
Какой лучше .NET Framework при разработке ?
maratovich
 
г. Самара
Регистрация: 12.07.2009
Сообщений: 2,462

Использовал Framework 3,5 с расчетом на то что это есть у всех и гарантировано будет работать.
С недавних пор Виндовс 10 начал игнорить включение 3,5, соответственно нужно переходить на новое.
Смотрю и ужасаюсь: 4,0....4,8
Они их штампуют.
Вопрос - сейчас актуальный 4,0 , будет ли везде работать или стоит использовать сразу 4,5
Но боюсь что 4,5 не у всех есть.
__________________
Вопрос : Где находится Тургай ? Ответ : Между Парагваем и Уругваем.....
Просмотров: 9059
 
Непрочитано 26.10.2020, 10:37
| 2 #2
trir


 
Регистрация: 18.12.2010
Сообщений: 4,511


от пользователей зависит
trir вне форума  
 
Непрочитано 26.10.2020, 11:15
#3
nickname2019


 
Регистрация: 18.11.2019
Сообщений: 850


Цитата:
Сообщение от trir Посмотреть сообщение
от пользователей зависит
По идее, нужно версии разные делать ПО в инсталляторе. Проверять у юзера ситуацию и устанавливать тот, который нужно.
nickname2019 вне форума  
 
Автор темы   Непрочитано 26.10.2020, 11:23
#4
maratovich


 
Регистрация: 12.07.2009
г. Самара
Сообщений: 2,462
Отправить сообщение для maratovich с помощью Skype™


Цитата:
Сообщение от nickname2019 Посмотреть сообщение
и устанавливать тот, который нужно.
Вот этого и не хотелось бы, это же не комплекс расчетов полёта на марс, а простая мелкая прога.
__________________
Вопрос : Где находится Тургай ? Ответ : Между Парагваем и Уругваем.....
maratovich вне форума  
 
Непрочитано 26.10.2020, 11:30
#5
Сергей812


 
Регистрация: 10.08.2013
Сообщений: 9,274


Если .Net для плагина - то зависит от ядра программы основной.

Если как COM-управляющая программа внешняя:
W7 -> гарантировано наличие Net 3.5
W8 -> 4.0
W10 -> 4.6

а что по соображениям безопасности W10 перестал поддерживать .Net 3.5 выпуска 2007 года - так это Майкрософт еще долго терпел)
Сергей812 вне форума  
 
Непрочитано 26.10.2020, 11:43
#6
Кулик Алексей aka kpblc
Moderator

LISP, C# (ACAD 200[9,12,13,14])
 
Регистрация: 25.08.2003
С.-Петербург
Сообщений: 38,115


Вроде как вскоре планируется выход вообще NET 5, где будут объединены Framework и Core. Вот это будет весело!
Offtop: Никто не в курсе, в ACAD можно загрузить DLL-сборку Core, а не Framework (версия ACAD до 2021 включительно)? Я как-то попытался, но... "Нам разум дал стальные руки-крюки", и что-то пошло не так.
__________________

---
Обращение ко мне - на "ты".
Все, что сказано - личное мнение.
Кулик Алексей aka kpblc вне форума  
 
Непрочитано 26.10.2020, 11:57
#7
trir


 
Регистрация: 18.12.2010
Сообщений: 4,511


Цитата:
вскоре планируется выход вообще NET 5
он уже устарел
trir вне форума  
 
Непрочитано 26.10.2020, 12:06
#8
Сергей812


 
Регистрация: 10.08.2013
Сообщений: 9,274


Цитата:
Сообщение от Кулик Алексей aka kpblc Посмотреть сообщение
в ACAD можно загрузить DLL-сборку Core
в качестве эксперимента .Net Standart сборку можно было бы попробовать загрузить, так как Standart = общие для Framework и Core функции.

----- добавлено через ~2 мин. -----
Цитата:
Сообщение от Кулик Алексей aka kpblc Посмотреть сообщение
Вроде как вскоре планируется выход вообще NET 5, где будут объединены Framework и Core. Вот это будет весело!
пускай профессиональные программисты обкатают его годик-другой, если конечно насильно не будут переводить в новых версиях плагинов для программ)
Сергей812 вне форума  
 
Автор темы   Непрочитано 26.10.2020, 12:25
#9
maratovich


 
Регистрация: 12.07.2009
г. Самара
Сообщений: 2,462
Отправить сообщение для maratovich с помощью Skype™


Вот сейчас не понял Вин 10, в папке только 4.0, а в установках 4,8 показывает...
Короче если для моей проги при разработке использовать 4,0, то полюбасу у всех будет работать, так ?
Миниатюры
Нажмите на изображение для увеличения
Название: нет.png
Просмотров: 34
Размер:	44.9 Кб
ID:	231282  Нажмите на изображение для увеличения
Название: нет2.png
Просмотров: 34
Размер:	15.5 Кб
ID:	231283  
__________________
Вопрос : Где находится Тургай ? Ответ : Между Парагваем и Уругваем.....
maratovich вне форума  
 
Непрочитано 26.10.2020, 12:29
#10
Сергей812


 
Регистрация: 10.08.2013
Сообщений: 9,274


на голой винде - с 8-ки, если там уже ставились программы - то и на семерке с большей вероятностью может быть до 4+ версии обновлено .Net.
Сергей812 вне форума  
 
Непрочитано 26.10.2020, 12:30
#11
trir


 
Регистрация: 18.12.2010
Сообщений: 4,511


Цитата:
то полюбасу у всех будет работать
у всех это у кого? кто то на xp может сидеть, на linux, Mac OS...
trir вне форума  
 
Непрочитано 26.10.2020, 12:34
#12
Сергей812


 
Регистрация: 10.08.2013
Сообщений: 9,274


угу, в маке искать фреймворк виндоуз) А так перекомпилирует приложение под 3.5 и будет под хп работать. Только при разработке надо внимательно справку читать - чтобы использовать только те компоненты/классы, которые в 3.5 версии уже были.
Сергей812 вне форума  
 
Непрочитано 26.10.2020, 12:37
#13
trir


 
Регистрация: 18.12.2010
Сообщений: 4,511


Цитата:
угу, в маке искать фреймфорк виндоуз)
можно поставить
trir вне форума  
 
Автор темы   Непрочитано 26.10.2020, 12:40
#14
maratovich


 
Регистрация: 12.07.2009
г. Самара
Сообщений: 2,462
Отправить сообщение для maratovich с помощью Skype™


Цитата:
Сообщение от trir Посмотреть сообщение
кто то на xp может сидеть
Вы издеваетесь ? ХР в прошлом.
Вот статистика по сайту:
Миниатюры
Нажмите на изображение для увеличения
Название: стат.png
Просмотров: 58
Размер:	24.6 Кб
ID:	231286  
__________________
Вопрос : Где находится Тургай ? Ответ : Между Парагваем и Уругваем.....
maratovich вне форума  
 
Непрочитано 26.10.2020, 12:42
#15
trir


 
Регистрация: 18.12.2010
Сообщений: 4,511


Цитата:
ХР в прошлом.
ну мы откуда знаем, может он стоит у важного клиента...
trir вне форума  
 
Непрочитано 26.10.2020, 12:49
#16
Сергей812


 
Регистрация: 10.08.2013
Сообщений: 9,274


Цитата:
Сообщение от trir Посмотреть сообщение
можно поставить
можно, под кросс-платформенный .Net Core) А речь в ветке идет о .Net FrameWork.

Цитата:
Сообщение от trir Посмотреть сообщение
ну мы откуда знаем, может он стоит у важного клиента...
важный клиент, у которого парк машин не обновлялся лет 10+ ?) Так он ничего и не купит из программ, несмотря на какой версии Фреймворка они написаны - в подобных конторах мышка по несколько месяцев покупалась на замену)
Сергей812 вне форума  
 
Непрочитано 26.10.2020, 13:01
#17
trir


 
Регистрация: 18.12.2010
Сообщений: 4,511


Цитата:
Никто не в курсе, в ACAD можно загрузить DLL-сборку Core, а не Framework (версия ACAD до 2021 включительно)?
как то работает...
Код:
[Выделить все]
    <Reference Include="System.Buffers, Version=4.0.2.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51, processorArchitecture=MSIL">
      <HintPath>..\packages\System.Buffers.4.4.0\lib\netstandard2.0\System.Buffers.dll</HintPath>
    </Reference>
    <Reference Include="System.Core" />
    <Reference Include="System.Memory, Version=4.0.1.1, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51, processorArchitecture=MSIL">
      <HintPath>..\packages\System.Memory.4.5.3\lib\netstandard2.0\System.Memory.dll</HintPath>
    </Reference>
    <Reference Include="System.Numerics" />
    <Reference Include="System.Numerics.Vectors, Version=4.1.4.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a, processorArchitecture=MSIL">
      <HintPath>..\packages\System.Numerics.Vectors.4.5.0\lib\net46\System.Numerics.Vectors.dll</HintPath>
    </Reference>
    <Reference Include="System.Runtime.CompilerServices.Unsafe, Version=4.0.4.1, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a, processorArchitecture=MSIL">
      <HintPath>..\packages\System.Runtime.CompilerServices.Unsafe.4.5.2\lib\netstandard2.0\System.Runtime.CompilerServices.Unsafe.dll</HintPath>
    </Reference>
trir вне форума  
 
Непрочитано 28.10.2020, 21:12
#18
Do$

AutoCAD/Civil3D LISP/C#
 
Регистрация: 15.08.2008
Санкт-Петербург
Сообщений: 1,702
Отправить сообщение для Do$ с помощью Skype™


Цитата:
Сообщение от maratovich Посмотреть сообщение
Использовал Framework 3,5 с расчетом на то что это есть у всех и гарантировано будет работать.
С недавних пор Виндовс 10 начал игнорить включение 3,5, соответственно нужно переходить на новое.
Смотрю и ужасаюсь: 4,0....4,8
Они их штампуют.
Вопрос - сейчас актуальный 4,0 , будет ли везде работать или стоит использовать сразу 4,5
Но боюсь что 4,5 не у всех есть.
У всех версий NET Framework 4.* среда исполнения (CLR) версии 4. Поэтому, что написано для NET Framework 4.0 будет работать во всех последующих, которые есть на сегодняшний день.
Более подробно - тут: https://docs.microsoft.com/ru-ru/dot...d-dependencies
Настолько подробно всё расписано там, что добавить даже нечего.

----- добавлено через ~5 мин. -----
Цитата:
Сообщение от Кулик Алексей aka kpblc Посмотреть сообщение
Offtop: Никто не в курсе, в ACAD можно загрузить DLL-сборку Core, а не Framework (версия ACAD до 2021 включительно)? Я как-то попытался, но... "Нам разум дал стальные руки-крюки", и что-то пошло не так.
А зачем? Какой смысл в кроссплатформенных приложениях для AutoCAD?
__________________
Толковый выбор приходит с опытом, а к нему приводит выбор бестолковый. (The Mechanic)
Do$ вне форума  
 
Автор темы   Непрочитано 28.10.2020, 21:20
#19
maratovich


 
Регистрация: 12.07.2009
г. Самара
Сообщений: 2,462
Отправить сообщение для maratovich с помощью Skype™


Цитата:
Сообщение от Do$ Посмотреть сообщение
Поэтому, что написано для NET Framework 4.0 будет работать во всех последующих, которые есть на сегодняшний день.
Пришел к выводу что делать лучше на 4.6 (по умолчанию в 10).
И задался вопросом - если завтра скажут что в 4.0 дыра в безопасности и её прикроют, 4.6 работать то будет или нет....
__________________
Вопрос : Где находится Тургай ? Ответ : Между Парагваем и Уругваем.....
maratovich вне форума  
 
Непрочитано 28.10.2020, 21:29
#20
Do$

AutoCAD/Civil3D LISP/C#
 
Регистрация: 15.08.2008
Санкт-Петербург
Сообщений: 1,702
Отправить сообщение для Do$ с помощью Skype™


Цитата:
Сообщение от maratovich Посмотреть сообщение
И задался вопросом - если завтра скажут что в 4.0 дыра в безопасности и её прикроют
Что прикроют? NET Framework 4.0? Так от него и так уже практически все ушли. Ему уже 10 лет, как-никак )
Но разрабатывать для него приложения можно и сегодня. И работать будет на всех новых фреймворках, пока у них исполняемая среда совместимой версии. Почитайте статью, на которую я ссылку дал - там всё расписано.
__________________
Толковый выбор приходит с опытом, а к нему приводит выбор бестолковый. (The Mechanic)
Do$ вне форума  
 
Непрочитано 28.10.2020, 21:31
#21
trir


 
Регистрация: 18.12.2010
Сообщений: 4,511


Цитата:
А зачем? Какой смысл в кроссплатформенных приложениях для AutoCAD?
вопрос не так стоит, вот есть либа - https://github.com/VPenades/SharpGLTF
она мне нужна, но там нет NET Framework
trir вне форума  
 
Непрочитано 28.10.2020, 21:34
#22
Do$

AutoCAD/Civil3D LISP/C#
 
Регистрация: 15.08.2008
Санкт-Петербург
Сообщений: 1,702
Отправить сообщение для Do$ с помощью Skype™


Цитата:
Сообщение от trir Посмотреть сообщение
как то работает...
Так это же NET Standard 2.0. Конечно будет работать, если приложение на AutoCAD пишется для NET Framework 4.6.2 и выше: https://docs.microsoft.com/ru-ru/dot...d/net-standard

----- добавлено через ~4 мин. -----
Цитата:
Сообщение от trir Посмотреть сообщение
вопрос не так стоит, вот есть либа - https://github.com/VPenades/SharpGLTF
она мне нужна, но там нет NET Framework
Есть NET Standard - это, можно условно сказать, некий аналог NET Framework в данном случае:
Цитата:
The library now multitargets NetStandard 2.0 and NetCore3.1
__________________
Толковый выбор приходит с опытом, а к нему приводит выбор бестолковый. (The Mechanic)
Do$ вне форума  
 
Непрочитано 28.10.2020, 21:45
#23
Кулик Алексей aka kpblc
Moderator

LISP, C# (ACAD 200[9,12,13,14])
 
Регистрация: 25.08.2003
С.-Петербург
Сообщений: 38,115


Цитата:
Сообщение от Do$ Посмотреть сообщение
А зачем? Какой смысл в кроссплатформенных приложениях для AutoCAD?
Было просто любопытно )
__________________

---
Обращение ко мне - на "ты".
Все, что сказано - личное мнение.
Кулик Алексей aka kpblc вне форума  
 
Непрочитано 28.10.2020, 21:45
#24
trir


 
Регистрация: 18.12.2010
Сообщений: 4,511


так то так, но есть нюанс, некоторые штуки, которые есть по умолчанию в NET Standard, в NET Framework это отдельные либы - и определить какие нужны иногда становится целым детективом
trir вне форума  
 
Автор темы   Непрочитано 28.10.2020, 22:47
#25
maratovich


 
Регистрация: 12.07.2009
г. Самара
Сообщений: 2,462
Отправить сообщение для maratovich с помощью Skype™


Цитата:
Сообщение от Do$ Посмотреть сообщение
Почитайте статью, на которую я ссылку дал - там всё расписано.
Суть вопроса не в этом.
Цитата:
Сообщение от Do$ Посмотреть сообщение
Так от него и так уже практически все ушли. Ему уже 10 лет, как-никак )
Первым делом нужно уважать пользователя, чтобы у него всё работало, а не заставлять его пихать в компьютер всё навороченное новое для мелких программ.
__________________
Вопрос : Где находится Тургай ? Ответ : Между Парагваем и Уругваем.....
maratovich вне форума  
 
Непрочитано 29.10.2020, 09:03
#26
Do$

AutoCAD/Civil3D LISP/C#
 
Регистрация: 15.08.2008
Санкт-Петербург
Сообщений: 1,702
Отправить сообщение для Do$ с помощью Skype™



Ну я тогда совсем не понимаю, в чём проблема.
Давайте попробуем с другого конца зайти. Программа самостоятельная - типа консольного приложения, приложения WinForm или WPF? Или это приложение под AutoCAD?
Если самостоятельная - то всё верно, ориентируйтесь на минимальную версию NET Framework, которая устанавливается вместе с ОС, в которой будут работать потенциальные пользователи. Об остальном уже позаботились ребята из Microsoft (взято отсюда):
Цитата:
.NET Framework 4.5 — это обновление на месте, которое заменяет .NET Framework 4 на компьютере, и аналогично .NET Framework 4.5.1, 4.5.2, 4,6, 4.6.1, 4.6.2, 4,7, 4.7.1, 4.7.2 и 4.8 — это обновления на месте для .NET Framework 4.5. Обновление на месте означает, что они используют ту же версию среды выполнения, но версии сборок обновлены и включают новые типы и члены. После установки одного из этих обновлений приложения .NET Framework 4, .NET Framework 4.5, .NET Framework 4.6 или .NET Framework 4.7 должны продолжать работу без повторной компиляции.
Если приложение под AutoCAD, то ориентируйтесь на требования по минимальной версии AutoCAD, который используют потенциальные пользователи. Но тут, желательно, всё же, выпускать отдельные версии приложений под каждую отдельную версию AutoCAD. Это связано с тем, что есть различия в AutoCAD .NET API в разных версиях AutoCAD. И, в таком случае, имеет смысл выставлять целевую версию NET Framework в соответствии с той, которую использует AutoCAD. Тогда вообще никаких проблем для пользователя в плане совместимости не будет - нужная версия NET Framework будет гарантированно установлена вместе с AutoCAD.
__________________
Толковый выбор приходит с опытом, а к нему приводит выбор бестолковый. (The Mechanic)
Do$ вне форума  
Ответ
Вернуться   Форум DWG.RU > Программное обеспечение > Программирование > Какой лучше .NET Framework при разработке ?

Размещение рекламы
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск


Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
Опрос. Какой язык программирования для автокада лучше. proektant-minsk Программирование 17 18.03.2020 19:42
На Mac OS X через Parallels Desktop 10 не могу установить AutoCAD, ошибка из-за .NET Framework Jony-pbp AutoCAD 14 16.09.2018 21:57
Фундамент на площадке с уклоном. Какой лучше? Юлия Серенко Основания и фундаменты 28 29.09.2014 13:10
Какой вариант шарнирного узла балки лучше с т.з. технологичности изготовления на заводе Metkon Металлические конструкции 4 26.03.2014 13:19
Какой лучше фундамент выбрать для типового павильона? Какой тип фундамента более универсален? ольга сычикова Основания и фундаменты 8 02.02.2011 12:58